[issue457] demandimport fail for mpatch

Shun-ichi Goto mercurial-bugs at selenic.com
Tue Dec 19 22:06:39 CST 2006


New submission from Shun-ichi Goto <shunichi.goto at gmail.com>:

I've updated to crew (ea238a4e9e8b 2006-12-19)
and I built and made binary by
  python setup.py build && python py2exe -b 1
But hg.exe diff fails for some command to load mpatch.pyd.
Other *.pyd modules seems to cause same error.
But when I built without bundling dlls by py2exe -b 3, it works.
Both python 2.3 and 2.4 goes same result.
This may be related to issue 453 but it seems an another thing.
------------
[c:\develop\hg\crew]dist\hg diff
** unknown exception encountered, details follow
** report bug details to http://www.selenic.com/mercurial/bts
** or mercurial at selenic.com
** Mercurial Distributed SCM (version ec0199c3f3d3)
Traceback (most recent call last):
  File "hg", line 11, in ?
    mercurial.commands.run()
  File "mercurial\commands.pyc", line 2965, in run
  File "mercurial\commands.pyc", line 3188, in dispatch
  File "mercurial\commands.pyc", line 3147, in <lambda>
  File "mercurial\commands.pyc", line 1029, in diff
  File "mercurial\patch.pyc", line 337, in diffopts
  File "mercurial\demandimport.pyc", line 71, in __getattribute__

  File "mercurial\demandimport.pyc", line 46, in _load
     
  File "zipextimporter.pyc", line 78, in load_module
  File "mercurial\mdiff.pyc", line 248, in ?
  File "mercurial\demandimport.pyc", line 71, in __getattribute__

  File "mercurial\demandimport.pyc", line 46, in _load
     
  File "zipextimporter.pyc", line 91, in load_module
  File "mercurial\demandimport.pyc", line 99, in _demandimport

AttributeError: 'module' object has no attribute 'mpatch'

----------
messages: 2555
nosy: gotoh
priority: bug
status: unread
title: demandimport fail for mpatch
topic: windows

____________________________________________________
Mercurial issue tracker <mercurial-bugs at selenic.com>
<http://www.selenic.com/mercurial/bts/issue457>
____________________________________________________



More information about the Mercurial-devel mailing list