[issue753] Installation never installs an executable on OSX

Jason Wilson mercurial-bugs at selenic.com
Fri Sep 28 01:40:06 CDT 2007


New submission from Jason Wilson <jasonaaronwilson at gmail.com>:

I already had python 2.3 and 2.4 installed.  I tried installing the most recent
mercurial I could find from http://mercurial.berkwood.com/ for 2.4:

http://mercurial.berkwood.com/binaries/Mercurial-0.9.4-bbdcdc7f170e-py2.4-macosx10.4.zip

This did result in files being put in
/Library/Frameworks/Python.framework/Versions/2.4/lib/python2.4/site-packages/

but nothing got put in /Library/Frameworks/Python.framework/Versions/Current/bin

I thought it might be a permission problem but i was able to touch a file called
foo in that directory.  The installation program never complained.

I also tried downloading python 2.5 thinking that a new install would cure any
strange permissions problem but again nothing code came of it.

http://mercurial.berkwood.com/binaries/Mercurial-0.9.4-bbdcdc7f170e-py2.5-macosx10.4.zip

So basically, your install process doesn't check itself and doesn't do the right
thing for me.  My friend reports that it was easy for him to install python and
mercurial.  I don't know why I ran into these problems when he didn't, but it
sucks because I would like to try out your software.

----------
messages: 4043
nosy: jawilson
priority: bug
status: unread
title: Installation never installs an executable on OSX

____________________________________________________
Mercurial issue tracker <mercurial-bugs at selenic.com>
<http://www.selenic.com/mercurial/bts/issue753>
____________________________________________________



More information about the Mercurial-devel mailing list