[PATCH 2 of 2] bundlerepo: fix inconsistency of parsed and internal name (issue #821)
peter.arrenbrecht at gmail.com
Sun Feb 10 12:27:41 CST 2008
On Feb 10, 2008 7:13 PM, Thomas Arendsen Hein <thomas at intevation.de> wrote:
> * Peter Arrenbrecht <peter.arrenbrecht at gmail.com> [20080210 08:15]:
> > + if path:
> > + self._url = 'bundle:' + path + '+' + bundlename
> > + else:
> > + self._url = 'bundle:' + bundlename
> Hmm, this is bundle://repo+bundle or bundle://bundle
> In issue821 you say "So I suspect bundle+repo is correct." and I'd
> say you're right there.
> Why did you change your mind?
If I remember correctly, it is what tonfa told me on IRC. But that is
quite some time ago. Since now one else had taken an interest then,
I'd let it slip.
Strangely enough, test-bundle did *not* fail with this change this
time. A quick look at the log shows no relevant changes. Either I had
tomatoes on my eyes then or now. In any case, the change does not
break any tests (at least those that weren't skipped on my box).
Given this, I think the usage that people might have been using at the
API level (as in `hg log bundle:repo+bundle`) is a little more
important to keep stable than what was reported to hooks. I may be
mistaken there, though.
More information about the Mercurial-devel