[PATCH] mq: introduce the qunmanage command

Paul Moore p.f.moore at gmail.com
Wed May 28 05:38:21 CDT 2008

On 28/05/2008, Dirkjan Ochtman <dirkjan at ochtman.nl> wrote:
> I'd like to one more time state that I still think qpromote is a better name.
> qmanage implies that revisions and patches are the same thing (moving in and
> out of mq control), which is not really the case, certainly not in the minds of new
> users. qpromote makes it clear that a patch in mq is really promoted to
> something else, a Mercurial revision. FWIW, jorendorff and cmason seem to
> agree qpromote is better. Using qpromote would mean retaining qimport as is; I
> think qimport is really a fine name.

I don't really like qmanage/qunmanage - they are hard to type and not
particularly intuitive.

My preference is for qpromote. I don't think it's perfect, but I'm not
sure I can come up with anything better.


More information about the Mercurial-devel mailing list