[issue1397] hg convert (CVS then SVN) fails with ValueError: need more than 1 value to unpack

Jesse Glick mercurial-bugs at selenic.com
Tue Nov 25 14:01:25 CST 2008

New submission from Jesse Glick <jesse.glick at sun.com>:

[Ubuntu; using either 1.0.2 or 07cb58b8c843 from crew.]

I checked out

:pserver:... at cvs.dev.java.net:/cvs nbmodules/hudson

and converted that to Hg:

hg convert cvsco hgrepo

This produced an shamap with entries like

1 91892ebe829e33d44ec64d48e7e5f984d728e8b7
2 597d76666000aba69abd379fa844362fd6ef48c0
19 ....

Then I have a checkout of


and I run

hg convert svnco hgrepo. I get

  File "/home/jglick/lib/python/hgext/convert/__init__.py", line 127, in convert
    return convcmd.convert(ui, src, dest, revmapfile, **opts)
  File "/home/jglick/lib/python/hgext/convert/convcmd.py", line 353, in convert
  File "/home/jglick/lib/python/hgext/convert/convcmd.py", line 275, in convert
  File "/home/jglick/lib/python/hgext/convert/subversion.py", line 225, in setrevmap
    uuid, module, revnum = self.revsplit(revid)
  File "/home/jglick/lib/python/hgext/convert/subversion.py", line 447, in revsplit
    url, revnum = rev.encode(self.encoding).split('@', 1)
ValueError: need more than 1 value to unpack

The 'rev' local variable in this case has the value '11'.

(I initially tried using a splicemap to make the first SVN rev be parented to
the last CVS rev, with the same results.)

Converting the SVN checkout into a separate Hg repo seems to work. (Is too slow
to actually wait for it to finish, probably for unrelated reasons.)

Issue1176 has a similar error message but there the user seems to be passing the
SVN checkout as the 2nd arg to convert, which I am not doing.

Issue1219 mentions a similar error in the middle of a lot of seemingly unrelated

Issue1305 mentions a similar error when dealing with filenames containing SPACE,
which I don't think is my case, and anyway is claimed to be fixed already.

messages: 7981
nosy: jglick
priority: bug
status: unread
title: hg convert (CVS then SVN) fails with ValueError: need more than 1 value to unpack
topic: svn

Mercurial issue tracker <mercurial-bugs at selenic.com>

More information about the Mercurial-devel mailing list