darcs test fails

Dirkjan Ochtman dirkjan at ochtman.nl
Thu Aug 6 02:40:57 CDT 2009

On Thu, Aug 6, 2009 at 09:28, Gilles Moris<gilles.moris at free.fr> wrote:
> I run a FC8 which embeds darcs 1.0.9 and test-convert-darcs was just running
> without problems. But since 6fd3f795e908 [1], this test fails because convert
> now requires darcs version >= 2.1.
> I first thought to a trivial patch, but test-convert-darcs starts by requiring
> darcs version < 2.x [2]. And if I remove this limitation, the test fails
> with darcs 2.2.0 [3].

Any patch should probably go into tests/hghave, not into convert.
Requiring a version in test-convert-darcs is also pretty bad.



More information about the Mercurial-devel mailing list