[issue1737] Local (hardlink) clone is ~60% slower under 1.3 than 1.2.1

Greg Ward mercurial-bugs at selenic.com
Mon Jul 13 15:16:08 CDT 2009


New submission from Greg Ward <greg-hg at gerg.ca>:

I discovered this while helping to reproduce issue1734, but I don't think they
are related.  Here's the demonstration:

$ hgs version    
Mercurial Distributed SCM (version 1.2.1)
$ time hgs clone -U repo1 repo2
hgs clone -U repo1 repo2  4.19s user 0.27s system 99% cpu 4.472 total
$ rm -rf repo2                 
$ time hgs clone -U repo1 repo2
hgs clone -U repo1 repo2  4.16s user 0.29s system 99% cpu 4.447 total
$ rm -rf repo2                 
$ time hgs clone -U repo1 repo2
hgs clone -U repo1 repo2  4.32s user 0.30s system 99% cpu 4.640 total

Average clone time: 4.52 sec.

Now compare with 8ec39725d966, which is right before the changeset that
introduced issue1734 (which absolutely destroyed local clone performance):

$ rm -rf repo2
$ time hgs clone -U repo1 repo2
hgs clone -U repo1 repo2  7.17s user 0.32s system 99% cpu 7.554 total
$ rm -rf repo2
$ time hgs clone -U repo1 repo2
hgs clone -U repo1 repo2  6.91s user 0.31s system 99% cpu 7.214 total
$ rm -rf repo2
$ time hgs clone -U repo1 repo2
hgs clone -U repo1 repo2  6.97s user 0.30s system 99% cpu 7.341 total

Average clone time: 7.37 sec.  Slowdown from hg 1.2.1 to not-quite-1.3: 63%.  Ouch!

----------
messages: 10028
nosy: gward
priority: bug
status: unread
title: Local (hardlink) clone is ~60% slower under 1.3 than 1.2.1
topic: performance

____________________________________________________
Mercurial issue tracker <mercurial-bugs at selenic.com>
<http://mercurial.selenic.com/bts/issue1737>
____________________________________________________



More information about the Mercurial-devel mailing list