[issue1898] hg server doesn't always honor -t (templates location)

Brent Yates bugs at mercurial.selenic.com
Tue Nov 3 14:52:19 CST 2009


New submission from Brent Yates <brent.yates at gmail.com>:

Started a web server using the following command:

hg serve -p8000 --webdir-conf "hgweb.cfg" -t "I:\WebServer\hg_templates"

where hg_templates contains all the standard Mercurial templates plus some 
custom ones. I get the following error message when viewing the main web 
page:

---------------------------------------------------------------------------

127.0.0.1 - - [03/Nov/2009 15:39:04] "GET / HTTP/1.1" 500 -
127.0.0.1 - - [03/Nov/2009 15:39:04] Exception happened during processing 
request '/':
Traceback (most recent call last):
  File "mercurial\hgweb\server.pyo", line 67, in do_POST
  File "mercurial\hgweb\server.pyo", line 60, in do_write
  File "mercurial\hgweb\server.pyo", line 124, in do_hgweb
  File "mercurial\hgweb\hgwebdir_mod.pyo", line 104, in __call__
  File "mercurial\hgweb\hgwebdir_mod.pyo", line 134, in run_wsgi
  File "mercurial\hgweb\hgwebdir_mod.pyo", line 325, in templater
  File "mercurial\templater.pyo", line 245, in stylemap
RuntimeError: No hgweb templates found in ['C:\\Program 
Files\\TortoiseHg\\templates']

127.0.0.1 - - [03/Nov/2009 15:39:04] "GET /favicon.ico HTTP/1.1" 500 -
127.0.0.1 - - [03/Nov/2009 15:39:04] Exception happened during processing 
request '/favicon.ico':
Traceback (most recent call last):
  File "mercurial\hgweb\server.pyo", line 67, in do_POST
  File "mercurial\hgweb\server.pyo", line 60, in do_write
  File "mercurial\hgweb\server.pyo", line 124, in do_hgweb
  File "mercurial\hgweb\hgwebdir_mod.pyo", line 104, in __call__
  File "mercurial\hgweb\hgwebdir_mod.pyo", line 134, in run_wsgi
  File "mercurial\hgweb\hgwebdir_mod.pyo", line 325, in templater
  File "mercurial\templater.pyo", line 245, in stylemap
RuntimeError: No hgweb templates found in ['C:\\Program 
Files\\TortoiseHg\\templates']
---------------------------------------------------------------------------


Platform: Windows XP Pro
Version: TortoiseHg 0.8.3

----------
messages: 10874
nosy: byates
priority: bug
status: chatting
title: hg server doesn't always honor -t (templates location)
topic: hgweb

____________________________________________________
Mercurial issue tracker <bugs at mercurial.selenic.com>
<http://mercurial.selenic.com/bts/issue1898>
____________________________________________________



More information about the Mercurial-devel mailing list