[issue2544] can't clone a repository (OSX 1.7.2+20101201)

Andy Fyfe bugs at mercurial.selenic.com
Sat Dec 11 22:12:38 CST 2010


New submission from Andy Fyfe <andy.fyfe at gmail.com>:

Any attempt to clone my repo gives the following error:

adding changesets
adding manifests                                                                                                                                         
adding file changes                                                                                                                                      
transaction abort!                                                                                                                                       
rollback completed                                                                                                                                       
abort: empty or missing revlog for 
platform/ops/scripts/CustomSegmentsEditor/public/.DS_Store

I get the same error if I use the --config format.dotencode=False option to 
clone (along with --pull, even specifying -r 0).

I tried an "hg rm" on the file.  I now can't revert: abort: 
data/platform/ops/scripts/CustomSegmentsEditor/public/.DS_Store.i at e8192f5ef5
e2: no match found!

hg log platform/ops/scripts/CustomSegmentsEditor/public/.DS_Store
changeset:   0:3b5429a81921
...

The original repo was created by pulling from perforce using the perfarce 
extension.  That repo was then cloned.  The "hg rm" was done in the second 
clone.  Neither repo can now be cloned.

----------
messages: 14613
nosy: afyfe
priority: bug
status: unread
title: can't clone a repository (OSX 1.7.2+20101201)

____________________________________________________
Mercurial issue tracker <bugs at mercurial.selenic.com>
<http://mercurial.selenic.com/bts/issue2544>
____________________________________________________


More information about the Mercurial-devel mailing list