[issue2568] Occasional IOError raised during push operations on Windows

Steve Borho bugs at mercurial.selenic.com
Fri Dec 24 14:26:35 CST 2010


New submission from Steve Borho <steve at borho.org>:

Pasting from the output log of the tortoisehg workbench.  I tried to do a 
push, got the error, pushed again and it worked.  This happens less than 
once a day, but I can get a full traceback if needed.

For the record, I'm running Sophos 7.6.21, but I don't believe this has 
changed recently so I don't suspect it's the source of this behavior change.

My home directory is on a local ntfs partition.

% hg --repository C:\thg-winbuild\thg push 
https://bitbucket.org/tortoisehg/stable/
warning: bitbucket.org certificate not verified (check web.cacerts config 
setting)
pushing to https://bitbucket.org/tortoisehg/stable/
searching for changes
warning: bitbucket.org certificate not verified (check web.cacerts config 
setting)
[Error 32] The process cannot access the file because it is being used by 
another process: 'c:\\users\\sborho\\appdata\\local\\temp\\hg-bundle-
sqzkpq.hg'
[command returned code 255 Fri Dec 24 14:12:12 2010]
thg% % hg --repository C:\thg-winbuild\thg push 
https://bitbucket.org/tortoisehg/thg/
warning: bitbucket.org certificate not verified (check web.cacerts config 
setting)
pushing to https://bitbucket.org/tortoisehg/thg/
searching for changes
no changes found
[command completed successfully Fri Dec 24 14:14:47 2010]

I've only noticed this on tip of default, but I do not run the stable branch 
all that often.  This was reproduced with hg version 5314cbb775f6.

----------
messages: 14770
nosy: sborho
priority: bug
status: unread
title: Occasional IOError raised during push operations on Windows

____________________________________________________
Mercurial issue tracker <bugs at mercurial.selenic.com>
<http://mercurial.selenic.com/bts/issue2568>
____________________________________________________


More information about the Mercurial-devel mailing list