[issue2701] mercurial package should provide an __version__ attribute

"Martin v. Löwis" <bugs@mercurial.selenic.co at mercurial.selenic.com "Martin v. Löwis" <bugs@mercurial.selenic.co at mercurial.selenic.com
Tue Mar 15 10:50:59 CDT 2011


New submission from Martin v. Löwis <martin at v.loewis.de>:

Mercurial currently has an __version__ module, which then has an version 
attribute. This is unfortunate, since the common convention is that the 
version attribute should be called __version__.

I'd like to request that mercurial changes to put an __version__ attribute 
into __init__.py; this version should conform to PEP 386.

----------
messages: 15656
nosy: loewis
priority: feature
status: unread
title: mercurial package should provide an __version__ attribute

____________________________________________________
Mercurial issue tracker <bugs at mercurial.selenic.com>
<http://mercurial.selenic.com/bts/issue2701>
____________________________________________________


More information about the Mercurial-devel mailing list