[PATCH 6 of 6] rename some variables to avoid shadowing module names/functions

Matt Mackall mpm at selenic.com
Tue May 3 14:48:26 CDT 2011

On Sun, 2011-05-01 at 14:16 -0500, timeless wrote:
>      def recover(self):
> -        lock = self.lock()
> +        repolock = self.lock()

Don't really like these changes, as this is our standard locking
pattern. It might be better to change the lock import.

Mathematics is the supreme nostalgia of our time.

More information about the Mercurial-devel mailing list