[issue2795] Nested repositories path url problem with mercurial 1.8.3

lucck bugs at mercurial.selenic.com
Wed May 4 16:03:54 CDT 2011


New submission from lucck <lucck at boff.pl>:

I upgraded mercurial from 1.8.2 to 1.8.3 i use simple project with
subrepositories (.hgsub)

collector = collector
isix = isix
libfoundation = libfoundation
libisixdrv-stm32 = libisixdrv-stm32
lib-stm32 = lib-stm32

the project structure is 
collector_app
      isix
      libfoundation
      libisixdrv-stm32
      lib-stm32
when i tried to clone repository using 1.8.2 everything worked ok, but after
upgrade to 1.8.3 when i tried to clone i got following error:

lucck at lucckpc:/tmp$ hg clone ssh://hg@sserver/collector_app
destination directory: collector_app
requesting all changes
adding changesets
adding manifests
adding file changes                                                        
                                                                      
added 2 changesets with 3 changes to 2 files                               
                                                                      
updating to branch default                                                 
                                                                      
pulling subrepo libisixdrv-stm32 from
ssh://hg@sserver//ollector_app/libisixdrv-stm32                            
                                
remote: mercurial-server: absolute paths are not supported                 
                                                                      
abort: no suitable response from remote hg!                                
                    

It seems that letter c was eaten when mercurial tried to fetch subrepository

----------
messages: 16172
nosy: lucck
priority: bug
status: unread
title: Nested repositories path url problem with mercurial 1.8.3

____________________________________________________
Mercurial issue tracker <bugs at mercurial.selenic.com>
<http://mercurial.selenic.com/bts/issue2795>
____________________________________________________


More information about the Mercurial-devel mailing list