[PATCH 0 of 1 RFC] revset: overload + symbol for workingdir revision
mpm at selenic.com
Sun May 8 17:15:55 CDT 2011
On Sun, 2011-05-01 at 18:51 +0900, Yuya Nishihara wrote:
> Matt Mackall wrote:
> > On Sun, 2011-05-01 at 17:57 +0900, Yuya Nishihara wrote:
> > > Hi,
> > >
> > > Is this obfuscating than useful?
> > '+' is probably too magical now that we've used it in revsets. We
> > probably need a short symbolic name.
> Hmm, according to this thread:
> 'wdir' or 'dir' is the candidate.
> Should it handled at localrepo like 'null' or 'tip'?
> or upper layer?
You know, we can probably use a wd() predicate rather than a symbol for
Mathematics is the supreme nostalgia of our time.
More information about the Mercurial-devel