Test failure with darcs 2.5.2

Greg Ward greg at gerg.ca
Wed Oct 19 21:15:27 CDT 2011

Just upgraded my desktop machine to Ubuntu 11.10, which includes darcs
2.5.2, and now test-convert-darcs.t is broken. I updated back to hg
1.9 and 1.9.3 and got the same failure. Haven't tried building an
older version of darcs; life is too short.

Excerpt from the failure:

@@ -81,7 +84,7 @@
 darcs is encoding agnostic, so it takes whatever bytes it's given

   $ darcs record -a -l -m 'p4: desc ñ' -A 'author ñ'
-  Finished recording patch 'p4: desc \xc3\xb1' (esc)
+  Finished recording patch 'p4: desc ??'

   Test latin-1 commit message

I tried doing some simple darcs operations out of the hg test
environment, and indeed it seems to replace non-ASCII characters in
console output with ?. WTF.

IMHO Mercurial's tests should not depend on unpredictable behaviour of
other tools, so I suggest changing the expectation here from

  Finished recording patch 'p4: desc \xc3\xb1' (esc)


  Finished recording patch 'p4: desc ..' (re)

Not sure if the same will work for all the failures in
test-convert-darcs.t ... but is anyone offended by this? (I.e. do you
think we should accomodate this quirk of darcs terminal output?)


More information about the Mercurial-devel mailing list