[PATCH 3 of 5] store: rename arguments/variables related with "opener" "vfs" or so

FUJIWARA Katsunori foozy at lares.dti.ne.jp
Mon Aug 13 03:29:18 CDT 2012


At Mon, 13 Aug 2012 09:31:38 +0200,
Adrian Buehlmann wrote:
> 
> On 2012-08-13 08:44, FUJIWARA Katsunori wrote:
> > 
> > At Sun, 12 Aug 2012 11:25:15 +0200,
> > Adrian Buehlmann wrote:
> >>

[snip]

> >> Perhaps this would have been simpler to review if there would have been
> >> one variable rename per patch (instead of doing multiple renames in the
> >> same patch).
> >>
> >> I don't know what Matt wants here though.
> > 
> > In fact, I wavered between renaming them at once (like this patch) and
> > renaming each below in separated patches.
> > 
> >   - openertype => vfstype
> >   - op => vfs
> > 
> > Then, I chose the former, because of just renaming, not so many, and
> > all of them are categorized as "var/arg related initialization of
> > stores".
> > 
> > Of course, I'll re-post separated one , if this fixing is not suitable
> > for Mercurial development style.
> 
> Personally, I would split this patch up into one variable rename per
> patch. IMHO, it doesn't really matter that much how many patches this
> ends producing. The patches will be very small and thus quickly reviewable.
> 
> If you rename two variables in one patch, then you combine two unrelated
> changes into one patch.
> 
> See also
> http://mercurial.selenic.com/wiki/OneChangePerPatch#Reviewability

I'll re-post separated ones.

----------------------------------------------------------------------
[FUJIWARA Katsunori]                             foozy at lares.dti.ne.jp


More information about the Mercurial-devel mailing list