[Bug 3651] New: summary/outgoing with largefiles shows "no remote repo" unexpectedly

bugzilla-daemon at bz.selenic.com bugzilla-daemon at bz.selenic.com
Fri Oct 5 10:46:47 CDT 2012


http://bz.selenic.com/show_bug.cgi?id=3651

          Priority: normal
            Bug ID: 3651
                CC: mercurial-devel at selenic.com, natosha at gmail.com
          Assignee: bugzilla at selenic.com
           Summary: summary/outgoing with largefiles shows "no remote
                    repo" unexpectedly
          Severity: bug
    Classification: Unclassified
                OS: All
          Reporter: foozy at lares.dti.ne.jp
          Hardware: All
            Status: UNCONFIRMED
           Version: unspecified
         Component: largefiles
           Product: Mercurial

When there is no file to upload, "hg summary --large" and "hg
outgoing --large" show "no remote repo" message, even though
valid remote repository is specified ("default", "default-push"
or on command line).

This can be reproduced script below:

========================================
HG="hg --config extensions.largefiles="

${HG} init src
echo a > src/a
${HG} -R src add --large src/a
${HG} -R src commit -m '#0'

${HG} -q clone src cloned

echo "==== summary ===="
${HG} -R cloned summary --large
echo "==== outgoing ===="
${HG} -R cloned outgoing --large
========================================

It is because that "getoutgoinglfiles()" returns None, not only
if no valid remote repository is specified, but also if there is
no file to upload.

-- 
You are receiving this mail because:
You are on the CC list for the bug.


More information about the Mercurial-devel mailing list