[PATCH 3 of 7 V3] revset: add a bumped revset
pierre-yves.david at logilab.fr
Wed Oct 17 12:39:30 CDT 2012
On Wed, Oct 17, 2012 at 12:26:07PM -0500, Kevin Bullock wrote:
> On Oct 17, 2012, at 7:18 AM, Pierre-Yves David wrote:
> > On Tue, Oct 16, 2012 at 05:02:32PM -0500, Kevin Bullock wrote:
> >> On Oct 16, 2012, at 3:48 PM, Pierre-Yves David wrote:
> >>> # HG changeset patch
> >>> # User Pierre-Yves David <pierre-yves.david at logilab.fr>
> >>> # Date 1350300187 -7200
> >>> # Node ID e36b56c8231211eb5276677a31be57bb8e275a13
> >>> # Parent 8192b7575461b04cd4797d59315a231f426aea77
> >>> revset: add a bumped revset
> >>> Select bumped changesets.
> >>> [...]
> >>> + bumped = obsmod.getobscache(repo, 'bumped')
> >> Do we not have a method to return the bumped changesets a bit more cleanly? Directly fetching into another module's cache seems a bit dirty to me.
> > This the the very official method to get the list of xxx changeset on the repo.
> > Maybe the fact it contains "cache" in its name is missleading.
> > The other higher level way would be to use the repo.set("bumped()") revset call.
> For the official record: we talked on IRC about changing the name of the function to 'getobsrevs', which more accurately reflects what it returns.
and the discussion is not yet closed. getobsrevs sound a bit too much "get
obsolete revs". That sound wrong when accessing a set of revision related to
obsolescence but not obsolete themself. (like in getobscache(repo, "unstable"))
The right name could be getobsrelsetrevs for "get obsolescence related set of
The current name may stay around until we gather all various mercurial cache
into a single place to ease cross invalidation.
-------------- next part --------------
A non-text attachment was scrubbed...
Size: 198 bytes
Desc: Digital signature
More information about the Mercurial-devel