[PATCH 0 of 1] the bundle() revset predicate introduced in 2.5
mads at kiilerich.com
Fri Feb 1 08:52:36 CST 2013
I'm posting this a bit too early or too late ... but for a reason.
I just noticed that 03e552aaae67 "bundle: add revset expression to show bundle
contents (issue3487)" will have its first release with 2.5. I suggest renaming
the predicate or holding it back a bit.
Some possible nice-to-haves for such a predicate - just to give some context -
- handling of more than 1 bundle and a way to filter on different bundles
- predicate for revisions _only_ found in the bundle (which I assume would be
_much_ more useful than the current behaviour and also simpler to implement
After the release of 2.5 I would like to suggest this unionrepo for inclusion
in Mercurial. It is very much like bundlerepo and do for now reuse the
'bundle()' predicate ... even though the name is very misleading.
I could of course try to introduce another predicate ... but it would also be
nice to reuse existing ones.
It could thus have some advantages if this bundle() predicate was renamed
before it was released and set in stone. It could perhaps be something like
'other()'. Or perhaps we could declare in 2.5 that it so far is 'unstable' and
subject to change.
This is not exactly an early warning, but still a warning ...
More information about the Mercurial-devel