[Bug 3842] New: problems when pushing with mercurial keyring in opensuse12.1

mercurial-bugs at selenic.com mercurial-bugs at selenic.com
Mon Feb 25 10:28:11 CST 2013


          Priority: normal
            Bug ID: 3842
                CC: mercurial-devel at selenic.com
          Assignee: bugzilla at selenic.com
           Summary: problems when pushing with mercurial keyring in
          Severity: bug
    Classification: Unclassified
                OS: Linux
          Reporter: GurceIsikyildiz at shufflemaster.com
          Hardware: PC
            Status: UNCONFIRMED
           Version: 2.4.1
         Component: Mercurial
           Product: Mercurial

I initially reported this issue on the "mercurial-keyring" bug-tracker, but the
author felt the issue lied within the "keyring" module it makes use of.


I've reported it on the "keyring" bug-tracker too.


Basically, after installing the mercurial keyring under opensuse 12.1, each
time I push I see the following error:

searching for changes
http authorization required
realm: Mecurial Repo
user: gurcei (fixed in .hg/hgrc)
ERROR:dbus.proxies:Introspect error on
:1.222:/org/freedesktop/secrets/aliases/default: dbus.exceptions.DBusException:
org.freedesktop.Secret.Error.NoSuchObject: The
'/org/freedesktop/secrets/aliases/default' object does not exist
ERROR:dbus.connection:Unable to set arguments
({'org.freedesktop.Secret.Item.Label': u'gurcei@@http://rapiddev/hg @
Mercurial', 'org.freedesktop.Secret.Item.Attributes': {'username':
u'gurcei@@http://rapiddev/hg', 'service': u'Mercurial'}},
dbus.Struct((dbus.ObjectPath('/org/freedesktop/secrets/session/s11'), '',
dbus.ByteArray('xxxxx'), 'application/octet-stream'), signature=None), True)
according to signature None: <type 'exceptions.TypeError'>: Expected a string
or unicode object
** Unknown exception encountered with possibly-broken third-party extension
** which supports versions unknown of Mercurial.
** Please disable mercurial_keyring and try your action again.
** If that fixes the bug please report it to the extension author.
** Python 2.7.2 (default, Aug 19 2011, 20:41:43) [GCC]
** Mercurial Distributed SCM (version 2.4.1)
** Extensions loaded: hgk, mercurial_keyring

Although recently, I had noticed that the hg-push via hg-keyring was working
successfully on another opensuse12.1 virtualbox I used.

When I compared the two, it turned out that the only major difference between
them was which version of mercurial was installed (the versions of
mercurial-keyring + keyring modules were identical).

The working opensuse 12.1 vbox used mercurial 2.4.

The non-working opensuse 12.1 vbox used mercurial 2.4.1. Upon downgrading to hg
v2.4, the hg push via the keyring worked!

As a test, I installed the latest mercurial v2.5.1, I still get the same error
message as above.

So for now, I'll stick with mercurial v2.4 to get around my problems. I'm not
sure on who's turf the bug lies exactly, but thought I'd better put this on
your radars too, just in-case, as this problem seems to have surfaced from the
changes in v2.4.1 and the problem persists till the latest v2.5.1.

You are receiving this mail because:
You are on the CC list for the bug.

More information about the Mercurial-devel mailing list