tortoiseHg versions

techware at techware at
Tue Jul 2 11:33:31 CDT 2013

When I run tortoiseHg on Ubuntu I receive the error "This version of TortoiseHg requires Mercurial version 1.9.n to 2.0.n, but found 2.2.2."

I tried correcting this by using apt-get purge to uninstall TortoiseHg and Mercurial, then do an apt-get autoremove and autoclean to get rid everything. Then I install Mercurial version 2.0.2 and TortoiseHg 2.2-1 and run thg again and it still gives me the error. The command hg --version says I have version 2.2.2 although I installed 2.0.2.

I get the similar same results when I install Mercurial version 2.6 and TortoiseHg 2.8 which give the error message "This version of TortoiseHg requires Mercurial version 2.4.n, but found 2.2.2."

I looked up Mercurial 2.4 for Ubuntu, but it is unstable and therefore apt-get cannot install it.

Do you know how I can fix this so I can run TortoiseHg? 


More information about the Mercurial-devel mailing list