[Bug 3930] New: since 2.6 hg status reports incorrectly files as missing

mercurial-bugs at selenic.com mercurial-bugs at selenic.com
Wed May 8 16:43:10 CDT 2013


          Priority: normal
            Bug ID: 3930
                CC: mercurial-devel at selenic.com
          Assignee: bugzilla at selenic.com
           Summary: since 2.6 hg status reports incorrectly files as
          Severity: bug
    Classification: Unclassified
                OS: Linux
          Reporter: david.konecny at oracle.com
          Hardware: PC
            Status: UNCONFIRMED
           Version: 2.6
         Component: Mercurial
           Product: Mercurial

Created attachment 1725
  --> http://bz.selenic.com/attachment.cgi?id=1725&action=edit
hg status output

Since today (that is after my Ubuntu upgraded my hg to 2.6 version) 'hg status'
reports dozens of files as missing, that is prefixed by "!", without real
reason. I found it quite puzzling and tried everything I could (hg revert the
file; delete file/whole folder in terminal and hg revert it; update to
different branch) but nothing seems to fix the problem. Then I noticed that all
my clones of the repository started to manifest the same problem and so I tried
to downgrade hg client to 2.5.4 and that indeed made the problem go away. Looks
like a problem in 2.6 release?

The files reported as missing are sitting on the disk and there is nothing
wrong with them. The repository I'm using is open source one:
http://hg.netbeans.org/web-main/ (it is quite big!).

Attached is the log showing output of:
* hg --version
* hg status
* hg revert + hg status

Thanks. Let me know if I can provide more info.

You are receiving this mail because:
You are on the CC list for the bug.

More information about the Mercurial-devel mailing list