[PATCH 1 of 5] summary: augment output with info from extensions

Kevin Bullock kbullock+mercurial at ringworld.org
Wed May 15 08:37:54 CDT 2013

On 14 May 2013, at 4:58 PM, Bryan O'Sullivan wrote:

> On Tue, May 14, 2013 at 12:18 PM, Kevin Bullock <kbullock+mercurial at ringworld.org> wrote:
>> Sure looks like it should be in its own patch.
> I respectfully disagree in this case. I'm all for keeping patches small and simple, but not to the extent that it becomes self-defeating by breaking up a very small change even further.

I was mostly expecting to see other uses of it in the same series. Now having glanced at the rest of the series, I see that's not the case, so rolling it into this patch is okay I guess.

>> Also, the name 'hooks' is misleading, since it's apparently unrelated to the existing pre/post-operation user-configured hooks.
> I thought about using "callback" instead, but I didn't like that, because it suggests that it's important that there be a callback present. 
> I used the term "hook" because this use has been common parlance for several decades. I also thought about "observer", but that invokes too much Java stupidity for me to be comfortable. Naming things is hard!

Agreed, and I don't have a better suggestion except to prefix it with a specifier of some kind -- extensionhook, wraphook or some such. 'observer' invokes memories of Objective-C rather than Java for me, so I'd be good with that too. ;)

pacem in terris / мир / शान्ति / ‎‫سَلاَم‬ / 平和
Kevin R. Bullock

More information about the Mercurial-devel mailing list