[PATCH] httpconnection: force SSLv3 if the ssl module is available

Antoine Pitrou solipsis at pitrou.net
Wed May 15 14:48:10 CDT 2013


On Wed, 15 May 2013 15:32:07 -0400
Augie Fackler <raf at durin42.com> wrote:
> # HG changeset patch
> # User Augie Fackler <raf at durin42.com>
> # Date 1368646190 14400
> #      Wed May 15 15:29:50 2013 -0400
> # Branch stable
> # Node ID 900ab7c23f9ed458a8fc58ad3db239de8568f87b
> # Parent  278057693a1ddb93f95fa641e30e7a966ac98434
> httpconnection: force SSLv3 if the ssl module is available

Why SSLv3? Is it so that SSLv2 is disabled?

Note that recent 2.7 versions disable SSLv2 ciphers:
http://hg.python.org/cpython/file/149340b3004a/Lib/ssl.py#l95

Regards

Antoine.




More information about the Mercurial-devel mailing list