[Bug 4177] New: hg cannot push or clone from remote repository

mercurial-bugs at selenic.com mercurial-bugs at selenic.com
Thu Feb 20 17:28:06 CST 2014


http://bz.selenic.com/show_bug.cgi?id=4177

          Priority: normal
            Bug ID: 4177
                CC: mercurial-devel at selenic.com
          Assignee: bugzilla at selenic.com
           Summary: hg cannot push or clone from remote repository
          Severity: bug
    Classification: Unclassified
                OS: Linux
          Reporter: gjergj.sheldija at gmail.com
          Hardware: PC
            Status: UNCONFIRMED
           Version: 2.6.3
         Component: Mercurial
           Product: Mercurial

Created attachment 1759
  --> http://bz.selenic.com/attachment.cgi?id=1759&action=edit
error during push

hi,

my current setup is as follows :
server mercurial 1.4 on centos 6.5
client mercurial 2.6.3 on ubuntu 13.10

since a couple of days i'm unable to push or clone from my repositories.
clone ends with abort: stream ended unexpectedly
push ends with attached error.

since apache's mod_proxy is installed i've tried to
avoid it via ProxyPass, but at no avail.

tried to see what was happenig with wireshark.
the whole process ends with the tcp.flags.reset eq 1
which i don't have no idea where it might come from.
tried doing the whole thing udnder different routers and using
a VPN. but i always receive the same error.

just to be sure i did a hg verify on the repos and it didn't
return any error.

on the other handtesting it with hg serve works perfectly.

regards
gj.

-- 
You are receiving this mail because:
You are on the CC list for the bug.


More information about the Mercurial-devel mailing list