[PATCH rfc] merge: use separate lists for each action type
mpm at selenic.com
Fri Feb 28 18:01:52 CST 2014
On Fri, 2014-02-28 at 01:53 +0100, Mads Kiilerich wrote:
> # HG changeset patch
> # User Mads Kiilerich <madski at unity3d.com>
> # Date 1393548524 -3600
> # Fri Feb 28 01:48:44 2014 +0100
> # Node ID 7eb6a98f39554adb8ceecb64a26b38474a96a9f2
> # Parent 433f05f1df32932ee94595c6b70b7125a26c7768
> merge: use separate lists for each action type
I think I'd prefer going to a dict of lists, using the existing letter
scheme. I expect we'll be adding new types here, so the tuple usage will
be annoying to maintain.
Mathematics is the supreme nostalgia of our time.
More information about the Mercurial-devel