[PATCH] revset: stop using a baseset instead of a plain list in _revsbetween

Pierre-Yves David pierre-yves.david at ens-lyon.org
Thu Sep 18 17:31:08 CDT 2014


# HG changeset patch
# User Pierre-Yves David <pierre-yves.david at fb.com>
# Date 1410933349 25200
#      Tue Sep 16 22:55:49 2014 -0700
# Node ID 87b2ff58de3039b36d60cf76599290f55254baed
# Parent  fe9a4c6649ec5c035c41f563cddfae8e75b31843
revset: stop using a baseset instead of a plain list in _revsbetween

The function internal code needs a list. Lets use a list.

diff --git a/mercurial/revset.py b/mercurial/revset.py
--- a/mercurial/revset.py
+++ b/mercurial/revset.py
@@ -76,11 +76,11 @@ def _revsbetween(repo, roots, heads):
     """Return all paths between roots and heads, inclusive of both endpoint
     sets."""
     if not roots:
         return baseset([])
     parentrevs = repo.changelog.parentrevs
-    visit = baseset(heads)
+    visit = list(heads)
     reachable = set()
     seen = {}
     minroot = min(roots)
     roots = set(roots)
     # open-code the post-order traversal due to the tiny size of


More information about the Mercurial-devel mailing list