[PATCH 2 of 6] patchbomb: mark ancient option deprecated

Sean Farley sean at farley.io
Fri Jul 17 12:39:39 CDT 2015


Matt Mackall <mpm at selenic.com> writes:

> # HG changeset patch
> # User Matt Mackall <mpm at selenic.com>
> # Date 1435271894 18000
> #      Thu Jun 25 17:38:14 2015 -0500
> # Node ID 854086eeb8f76a7c85ebe2f6d266bde152abe9c3
> # Parent  f95092ecc0ee2394840861d083cf2a2594dd839f
> patchbomb: mark ancient option deprecated
>
> This just exists for backwards compatibility with the earliest
> versions of patchbomb.
>
> diff -r f95092ecc0ee -r 854086eeb8f7 hgext/patchbomb.py
> --- a/hgext/patchbomb.py	Thu Jun 25 17:37:35 2015 -0500
> +++ b/hgext/patchbomb.py	Thu Jun 25 17:38:14 2015 -0500
> @@ -514,6 +514,7 @@
>      def genmsgid(id):
>          return '<%s.%s@%s>' % (id[:20], int(start_time[0]), socket.getfqdn())
>  
> +    # deprecated config: patchbomb.from
>      sender = (opts.get('from') or ui.config('email', 'from') or
>                ui.config('patchbomb', 'from') or
>                prompt(ui, 'From', ui.username()))
> @@ -635,7 +636,7 @@
>                  fp.close()
>          else:
>              if not sendmail:
> -                verifycert = ui.config('smtp', 'verifycert')
> +                verifycert = ui.config('smtp', 'verifycert', 'strict')

Perhaps I don't understand the 'from' config and how it relates to
'verifycert' but this seems like an unrelated change.


More information about the Mercurial-devel mailing list