[PATCH evolve-ext] evolve: remove unused warning message in _solvedivergent

Laurent Charignon lcharignon at fb.com
Thu Jun 25 19:16:39 CDT 2015


# HG changeset patch
# User Laurent Charignon <lcharignon at fb.com>
# Date 1435189104 25200
#      Wed Jun 24 16:38:24 2015 -0700
# Node ID a8dbf56d316ff524d36c1918f82f2d74f09d29fe
# Parent  d3328e6775b1f23c6ab41ccd8712e02abb6eea72
evolve: remove unused warning message in _solvedivergent

Before this patch, we were checking for a case where a divergent changeset could
be public and printing a warning in that case. When we compute the divergent set
in the obsolete module we explicitely look for not public() changesets.
This patch removes this unused warning.

diff --git a/hgext/evolve.py b/hgext/evolve.py
--- a/hgext/evolve.py
+++ b/hgext/evolve.py
@@ -1846,12 +1846,6 @@ def _solvedivergent(ui, repo, divergent,
         ui.write_err(msg)
         return 2
     other = others[0]
-    if divergent.phase() <= phases.public:
-        msg = _("skipping %s: we can't resolve divergence from the public side\n") % divergent
-        ui.write_err(msg)
-        hint = _("(%s is public, try from %s)\n" % (divergent, other))
-        ui.write_err(hint)
-        return 2
     if len(other.parents()) > 1:
         msg = _("skipping %s: divergent changeset can't be a merge (yet)\n" % divergent)
         ui.write_err(msg)


More information about the Mercurial-devel mailing list