[PATCH evolve-ext] bookmarks: update to use new readactive api

Pierre-Yves David pierre-yves.david at ens-lyon.org
Thu May 7 16:37:44 CDT 2015



On 05/07/2015 02:32 PM, Augie Fackler wrote:
> On Thu, May 7, 2015 at 4:49 PM, Pierre-Yves David
> <pierre-yves.david at ens-lyon.org> wrote:
>> Can you make a small compatibility layer so that we do not have to bump the
>> version of Mercurial required?
>
>
> I explicitly asked the changes in hg to not have compat paths because
> it's better for extensions to break violently than to emit warnings
> that will only annoy users and never be seen by extension authors.

This request apply evolve side. Evolve can have a 3 lines functions that 
prevent 3 minor call to force people to upgrade mercurial to get new 
evolve feature and fixes. Expecially user like mpm who love to jump 
between stable and default branch of Mercurial all the time.

So everybody relax, this is an evolve-ext patch, I'm requesting change 
to the evolve-ext patch.

(On the warning side, this is what devel-warn are made for ☺)

-- 
Pierre-Yves David


More information about the Mercurial-devel mailing list