[PATCH evolve-ext] bookmarks: update to use new bookmarks api via compatibility layer

Matt Mackall mpm at selenic.com
Sun May 10 15:02:26 CDT 2015


On Sat, 2015-05-09 at 18:59 -0700, Ryan McElroy wrote:
> # HG changeset patch
> # User Ryan McElroy <rmcelroy at fb.com>
> # Date 1431030011 25200
> #      Thu May 07 13:20:11 2015 -0700
> # Branch stable
> # Node ID 3a177ff325cc2d6fef34eaf35ace9e4e550deb86
> # Parent  1218ad94a351b8294a4627a0ec9a27b68206c5b9
> bookmarks: update to use new bookmarks api via compatibility layer
> 
> Tested against 3.4 and latest hg + upcoming bookmarks patches

I locally had to make 3 hacks to get "hg next" working for my usual
review process: activate / deactivate / repo._activebookmark. I only see
two of them here.

-- 
Mathematics is the supreme nostalgia of our time.



More information about the Mercurial-devel mailing list