[PATCH] dispatch: do not construct repo for chgserver

Jun Wu quark at fb.com
Sat Feb 20 17:53:22 EST 2016

On 02/19/2016 03:10 PM, Yuya Nishihara wrote:
> I have patches that will replace 'dispatch.norepo' list by 'func.norepo'
> boolean. It could be

I like this direction.

> norepo =
>     | boolean
>     | callable(ui, *args, **opts) -> boolean

This feels simpler.

> needsrepo =
>     | no
>     | yes
>     | optional
>     | callable(ui, *args, **opts) -> no|yes|optional

This may require additional refactoring on "optionalrepo".

I guess we cannot deprecate things easily. Adding a new keyword will
make the interface more cumbersome (especially for new developers).
I prefer the first approach.
Do you have patches ready? Otherwise I can work on this.

More information about the Mercurial-devel mailing list