[remotefilelog] rfc: store refactor

Augie Fackler raf at durin42.com
Wed Mar 23 13:30:05 EDT 2016


> On Mar 20, 2016, at 20:07, Durham Goode <durham at fb.com> wrote:
> 
> This is mainly aimed at Augie, but the refactor I did to remotefilelog to make it adhere to the ContentStore / MetadataStore pattern can be found here: https://bitbucket.org/DurhamG/remotefilelog/commits/branch/newstore  (20 patches, 44d67fe through 14125f8).  It's mostly code reorganization, so it's not as scary to review as it looks (there's very little new logic).
> 
> There's a bunch of naming issues (basestore.contains() is a bad name; ioutil should be moved into shallowutil; etc), but I'll probably fix that stuff as follow up patches.  All the tests pass for every commit.
> 
> Augie, take a look if you get a chance.  Otherwise I'll get someone at FB to review it before I push it.

I went through these and ended up making some comments using bitbucket's inline commenting - most of what I had to say was "more docs" or "I don't like this name" over all, it seems like a good restructuring of the code. I think it might introduce enough architecture into remotefilelog that some sort of "how it works" doc might be helpful for newcomers, but we can always add that later if it ends up being a problem. Thanks!


More information about the Mercurial-devel mailing list