[PATCH 4 of 4] run-tests: use canonpath for with-python3

timeless timeless at mozdev.org
Mon Mar 28 00:03:17 EDT 2016


# HG changeset patch
# User timeless <timeless at mozdev.org>
# Date 1459137727 0
#      Mon Mar 28 04:02:07 2016 +0000
# Node ID 03daa91865a67720f75ae4a595214c02b3299bef
# Parent  7f96bdcef62d5f99417097ee441864298d1e4bd3
run-tests: use canonpath for with-python3

diff --git a/tests/run-tests.py b/tests/run-tests.py
--- a/tests/run-tests.py
+++ b/tests/run-tests.py
@@ -368,6 +368,7 @@
             parser.error('--with-python3 cannot be used when executing with '
                          'Python 3')
 
+        options.with_python3 = canonpath(options.with_python3)
         # Verify Python3 executable is acceptable.
         proc = subprocess.Popen([options.with_python3, b'--version'],
                                 stdout=subprocess.PIPE,


More information about the Mercurial-devel mailing list