[PATCH 1 of 2] config: rename allowpull to allow-pull

Yuya Nishihara yuya at tcha.org
Sun Nov 12 04:43:23 EST 2017


(+CC the list)

On Sun, 12 Nov 2017 10:05:07 +0100, David Demelier wrote:
> On Sun, Nov 12, 2017 at 05:16:06PM +0900, Yuya Nishihara wrote:
> > > diff -r 407ec7f3ff02 -r 4157480049da mercurial/help/config.txt
> > > --- a/mercurial/help/config.txt	Tue Nov 07 13:48:33 2017 -0800
> > > +++ b/mercurial/help/config.txt	Thu Oct 19 11:43:19 2017 +0200
> > > @@ -2287,7 +2287,7 @@
> > >      revisions.
> > >      (default: False)
> > >  
> > > -``allowpull``
> > > +``allow-pull``
> > >      Whether to allow pulling from the repository. (default: True)
> > 
> > Nit: Perhaps we should list the deprecated name as well.
> > 
> 
> Something like this?
> 
>     allow-pull (formerly allowpull)

Yeah, something like that. It would be nice if we could list more than one
terms, but our rst renderer appears to not support it.

  ``allow-pull``
  ``allowpull`` (DEPRECATED)
    blah blah...


More information about the Mercurial-devel mailing list