D5358: rust: peek_mut optim for lazy ancestors

Yuya Nishihara yuya at tcha.org
Tue Dec 4 07:38:53 EST 2018


Queued, thanks.

> +        let parents = self
> +            .graph
> +            .parents(current)
> +            .unwrap_or((NULL_REVISION, NULL_REVISION));
> +        let p0 = parents.0;

I've renamed it to `p1` since that's the convention of Mercurial codebase.

Maybe it can be rewritten as `let (p1, p2) = parents` to get rid of confusing
tuple indexing.


More information about the Mercurial-devel mailing list