[Bug 6185] New: convert with --filemap fails with any (even dummy) rename

mercurial-bugs at mercurial-scm.org mercurial-bugs at mercurial-scm.org
Fri Aug 9 04:30:34 EDT 2019


https://bz.mercurial-scm.org/show_bug.cgi?id=6185

            Bug ID: 6185
           Summary: convert with --filemap fails with any (even dummy)
                    rename
           Product: Mercurial
           Version: unspecified
          Hardware: All
                OS: All
            Status: UNCONFIRMED
          Severity: bug
          Priority: wish
         Component: convert
          Assignee: bugzilla at mercurial-scm.org
          Reporter: dinumarina at gmail.com
                CC: durin42 at gmail.com, mercurial-devel at mercurial-scm.org

I am trying to clean up a repository using hg convert --filemap. Convert works
fine with any option in filemap except rename. If I add any rename option to
filemap then it fails at the first merge with 

abort: unable to convert merge commit since target parents do not merge cleanly

I tried putting in filemap only a dummy:

rename foo bar 

(none of the foo or bar paths actually exist in the repo) and I get the same
result. I tried putting in a real rename (existing 1st path), same happens. As
fast as any rename gets in there, it breaks. It is a bug? What am I doing
wrong?

-- 
You are receiving this mail because:
You are on the CC list for the bug.


More information about the Mercurial-devel mailing list