D6553: shelve: move shelve extension to core

pulkit (Pulkit Goyal) phabricator at mercurial-scm.org
Thu Jul 4 11:00:35 EDT 2019


pulkit added inline comments.

INLINE COMMENTS

> commands.py:6207
> +    with repo.wlock():
> +        return shelvemod._dounshelve(ui, repo, *shelved, **opts)
> +

I just noticed that the function `_dounshelve()` still has `_` prefix. We generally have that to mark if functions are local to that file or class. So can you send a followup and rename that to `dounshelve`?

REPOSITORY
  rHG Mercurial

CHANGES SINCE LAST ACTION
  https://phab.mercurial-scm.org/D6553/new/

REVISION DETAIL
  https://phab.mercurial-scm.org/D6553

To: navaneeth.suresh, #hg-reviewers, pulkit
Cc: yuja, martinvonz, pulkit, Kwan, mjpieters, mercurial-devel


More information about the Mercurial-devel mailing list