D6605: unshelve: rename _dounshelve() to dounshelve()

navaneeth.suresh (Navaneeth Suresh) phabricator at mercurial-scm.org
Sun Jul 7 09:15:02 EDT 2019


Closed by commit rHG70f1a84d0794: unshelve: rename _dounshelve() to dounshelve() (authored by navaneeth.suresh).
This revision was automatically updated to reflect the committed changes.

REPOSITORY
  rHG Mercurial

CHANGES SINCE LAST UPDATE
  https://phab.mercurial-scm.org/D6605?vs=15762&id=15784

CHANGES SINCE LAST ACTION
  https://phab.mercurial-scm.org/D6605/new/

REVISION DETAIL
  https://phab.mercurial-scm.org/D6605

AFFECTED FILES
  mercurial/commands.py
  mercurial/shelve.py

CHANGE DETAILS

diff --git a/mercurial/shelve.py b/mercurial/shelve.py
--- a/mercurial/shelve.py
+++ b/mercurial/shelve.py
@@ -845,7 +845,7 @@
         hint = _("run hg status to see which files are missing")
         raise error.Abort(m, hint=hint)
 
-def _dounshelve(ui, repo, *shelved, **opts):
+def dounshelve(ui, repo, *shelved, **opts):
     opts = pycompat.byteskwargs(opts)
     abortf = opts.get('abort')
     continuef = opts.get('continue')
diff --git a/mercurial/commands.py b/mercurial/commands.py
--- a/mercurial/commands.py
+++ b/mercurial/commands.py
@@ -6209,7 +6209,7 @@
        prevents from deciding exact order of them, for safety.
     """
     with repo.wlock():
-        return shelvemod._dounshelve(ui, repo, *shelved, **opts)
+        return shelvemod.dounshelve(ui, repo, *shelved, **opts)
 
 @command('update|up|checkout|co',
     [('C', 'clean', None, _('discard uncommitted changes (no backup)')),



To: navaneeth.suresh, #hg-reviewers, pulkit
Cc: mercurial-devel


More information about the Mercurial-devel mailing list