D6478: shelve: first prototype of storing unresolved changes

pulkit (Pulkit Goyal) phabricator at mercurial-scm.org
Mon Jun 10 18:45:34 EDT 2019


pulkit added inline comments.

INLINE COMMENTS

> shelve.py:435
>  
> +def _storeunresolvedmerge(repo, name):
> +    if not repo.vfs.exists('merge-unresolved'):

the function needs documentation on what this does and why it does so.

> shelve.py:606
>              continue
> +        if repo.vfs.exists('merge-unresolved/%s' % sname):
> +            sname += ' (unresolved)'

okay, then let's move this one liner to a separate function. Something like `isunresolvedshelve(..)` which does the repo.vfs.exists() thing.

> shelve.py:1094
> +          ('', 'unresolved', None,
> +           _('unshelve mergestate with unresolved files'))] + cmdutil.walkopts,
>           _('hg shelve [OPTION]... [FILE]...'),

nit: will be nice to keep `)] + cmdutil.walkopts,` to a new line. as it was before.

REPOSITORY
  rHG Mercurial

REVISION DETAIL
  https://phab.mercurial-scm.org/D6478

To: navaneeth.suresh, #hg-reviewers
Cc: pulkit, mercurial-devel


More information about the Mercurial-devel mailing list