D2010: check-commit: allow foo_bar naming in functions

pulkit (Pulkit Goyal) phabricator at mercurial-scm.org
Sat Mar 16 18:28:30 EDT 2019


pulkit added a comment.


  In https://phab.mercurial-scm.org/D2010#89433, @martinvonz wrote:
  
  > In https://phab.mercurial-scm.org/D2010#89337, @indygreg wrote:
  >
  > > Should we queue this patch or abandon it?
  >
  >
  > I'm for it, even though it leads to inconsistency. However, we may want to discuss ahead of time what our long-term plan for existing symbols is. Do we eventually want to remove that inconsistency? I took a quick look for examples where it seemed obviously not worth it to rename and it was harder to find good examples than I had expected. Perhaps `bail_if_changed` and `extensions.wrap_function` are some of the more frequently used. But most very commonly used functions seem to have short names already. So maybe even if we wanted to eventually make it consistent, it won't be as bad as people have feared? I still don't feel very strongly, but I wanted to highlight what it would mean in practice.
  
  
  extensions.wrap_function is one of the most used function by extensions and I will be happy if we don't rename it. Renaming it will break a lot of extensions, let's prevent it.

REPOSITORY
  rHG Mercurial

REVISION DETAIL
  https://phab.mercurial-scm.org/D2010

To: indygreg, #hg-reviewers, pulkit, durin42
Cc: martinvonz, av6, yuja, durin42, pulkit, mercurial-devel


More information about the Mercurial-devel mailing list