D7299: rust-status: return a ParallelIterator instead of a Vec from stat_dmap_entries

kevincox (Kevin Cox) phabricator at mercurial-scm.org
Thu Nov 7 13:22:48 EST 2019


kevincox added inline comments.
kevincox accepted this revision.

INLINE COMMENTS

> status.rs:128
> +            Err(e) => return Err(e.into()),
> +        };
>  

This can be replaced with:

  let meta = root_dir.as_ref().join(hg_path_to_path_buf(filename)?).symlink_metadata();

Although I would probably also put `hg_path_to_path_buf(filename)?` into a variable for readability.

REPOSITORY
  rHG Mercurial

CHANGES SINCE LAST ACTION
  https://phab.mercurial-scm.org/D7299/new/

REVISION DETAIL
  https://phab.mercurial-scm.org/D7299

To: Alphare, #hg-reviewers, kevincox
Cc: durin42, kevincox, mercurial-devel


More information about the Mercurial-devel mailing list