[changeset b4b1131187c4 does not work under Ubuntu 16.04] (was: Ubuntu 16.04: can't compile stable branch)

Matt Harbison mharbison72 at gmail.com
Fri Oct 25 12:38:37 EDT 2019


> On Oct 25, 2019, at 11:55 AM, Uwe Brauer <oub at mat.ucm.es> wrote:
> 
> 
>>> On Thu, 24 Oct 2019 13:21:47 -0400, Uwe Brauer <oub at mat.ucm.es> wrote:
>> 
>> It looks like you're building with py2, and the latest packaging
>> apparently only supports py3.  Try updating to '7574ccd87200^' (note
>> the hat) and building that.
> 
> 
> I successfully build the deb, for changeset  b4b1131187c, 
> but when I run 
> hg --version 
> 
> I obtain an error:
> ,----
> | 
> | Traceback (most recent call last):
> |   File "/usr/lib/python2.7/dist-packages/mercurial/extensions.py", line 247, in _runuisetup
> |     uisetup(ui)
> |   File "/home/oub/.local/lib/python2.7/site-packages/hgext3rd/evolve/exthelper.py", line 149, in finaluisetup
> |     c(ui)
> |   File "/home/oub/.local/lib/python2.7/site-packages/hgext3rd/evolve/__init__.py", line 1360, in setupevolveunfinished
> |     cmdutil.unfinishedstates.append(data)
> | AttributeError: 'module' object has no attribute 'unfinishedstates'
> | *** failed to set up extension evolve: 'module' object has no attribute 'unfinishedstates'
> `----

This is crashing in the evolve extension. Try updating it to the latest stable, or failing that, default. (But I think this change was from a release or two ago)


More information about the Mercurial-devel mailing list