D7869: rust-dirs-multiset: add `DirsChildrenMultiset`

kevincox (Kevin Cox) phabricator at mercurial-scm.org
Wed Jan 15 10:06:23 EST 2020


kevincox added inline comments.
kevincox accepted this revision.

INLINE COMMENTS

> dirs_multiset.rs:170
> +                Some(i) => i.contains(&directory),
> +            } {
> +                continue;

I would put this check into a helper function.

> files.rs:86
> +                )),
> +            },
> +            None => None,

This should probably be a helper on `HgPath`? It would be much easier to understand what it is doing if it had a name.

REPOSITORY
  rHG Mercurial

CHANGES SINCE LAST ACTION
  https://phab.mercurial-scm.org/D7869/new/

REVISION DETAIL
  https://phab.mercurial-scm.org/D7869

To: Alphare, #hg-reviewers, kevincox
Cc: durin42, kevincox, mercurial-devel


More information about the Mercurial-devel mailing list