D7870: rust-utils: add `PrettyPrint` trait

kevincox (Kevin Cox) phabricator at mercurial-scm.org
Wed Jan 15 10:16:38 EST 2020


kevincox added a comment.
kevincox accepted this revision.


  I'm not convinced PrettyPrint is the best name. I might call it something more to do with escaping instead of "pretty". However I can't think of anything great.

INLINE COMMENTS

> utils.rs:146
> +                acc.push(HEX_DIGITS[((*c & 0xf0) >> 4) as usize]);
> +                acc.push(HEX_DIGITS[(*c & 0xf) as usize]);
> +            }

write!(acc, "\\x{:x}", self).unwrap();

REPOSITORY
  rHG Mercurial

CHANGES SINCE LAST ACTION
  https://phab.mercurial-scm.org/D7870/new/

REVISION DETAIL
  https://phab.mercurial-scm.org/D7870

To: Alphare, #hg-reviewers, kevincox
Cc: durin42, kevincox, mercurial-devel


More information about the Mercurial-devel mailing list