apache repository setup

John Evans johnevans123 at hotmail.com
Tue Aug 9 16:08:02 CDT 2005

>You're not running Windows are you? (I think I found something that might 
>cause a problem on Windows.*)
my no. :)

>Have you run ssh by hand against that particular server before? (it dumps 
>stuff other than what is expected if you haven't)
yes. I can ssh as root into je-server1 just fine.

>Try some basic looking around and see if you can identify what's going on 
>on the server side:
>ssh je at je_server1 "ls"
>ssh je at je_server1 "ls /~/je-repo"
>ssh je at je_server1 "ls /~/je-repo/.hg"

hmm. all of these work fine!

>In case for some strange reason it's a permissions issue, try touch'ing a 
>file in your home folder, and in the repo:
>ssh je at je_server1 "touch ~/asdf1"
>ssh je at je_server1 "touch ~/je-repo/asdf1"

ah. looks like i can read but not write.  the touch cmds fail, but a "ls -l" 

>None of this is expected to be a solution, but to establish some facts 
>about what works and what doesn't.
>I even ran something like the following against a repo of mine(I had never 
>tried this before today). It should return the same as running the command 
>ssh je at je_server1 "hg -R ~/je-repo verify"

the verify worked fine also.  so, looks like "write" access is not working.
so, if i chmod the entire .hg tree to 777... then i can now hg push if
I am user "je", but get a permissions error when another user "guestuser"
tries to push the next time.  looks like there are some files created
that have group and owner of "je", and only write permission for the owner, 
so, that means another user (e.g. guestuser) can not push into this same 
now, if i login as guestuser, but then use an ssh login as "je" to do the 
i.e. "hg push ssh://je@je_server1/~/je-repo", then i can push guestuser's
local repository modifications into je-repo but as user je.  hmm, not the 
but maybe ok for now.  I would rather have a record of users commits, 
of just a single user name.

very much appreciate the help Andrew,
so right now in summary I have to:
1) chmod 777 all the repository
2) have to push with only the original user ("je" in this case)

if you  have additional thoughts.. i'll give'em a try. i'm not sure
where to go from here, but will look at maybe mercurial permissions
on file creations.  i could put all the users into a single group, then
if mercurial would give me group write permissions on any .hg files created
then that might work...

Express yourself instantly with MSN Messenger! Download today - it's FREE! 

More information about the Mercurial mailing list