bug on pulling/cloning : patch cannot be decoded ! or consistency error adding group!

Mathieu Clabaut mathieu.clabaut at gmail.com
Fri Nov 17 17:02:59 CST 2006

On 11/17/06, Benoit Boissinot <bboissin at gmail.com> wrote:
> On 11/17/06, Mathieu Clabaut <mathieu.clabaut at gmail.com> wrote:
> > On 11/17/06, Benoit Boissinot <bboissin at gmail.com> wrote:
> > >
> > > > I tried to do an hg clone locally on the server, and it worked.
> > > > The problem is reproducible on the distant machine.
> > > > On the server side a "hg clone http://localhost/hg/c099 " failed
> too.
> > > >
> > > Sounds like a apache (or http server problem) can you test with hg
> serve ?
> >
> >
> > Good guess !
> > It works like a charm with hg serve (at least for the clone, didn't try
> the
> > pull)...
> > Any insight on what may cause the problem on apache ?
> No idea, I guess you should try wireshark/ethereal to see if you can
> spot a difference between the streams, maybe hg is tracebacking due a
> permission problem and corrupting the stream.

Yes !
Following the TCP streams gives me a backtrace due to :
 OError: [Errno 13] Permission denied....

 Good analysis. Thank you very much for your help !

 I think it may not be an uncommon error. Wouldn't be good, either to have a
mean to log the backtrace on the server side, or better, when
RevlogError(_("consistency error adding group")) is raised, have a look at
the incoming data to check if the client didn't get a backtrace, and if it
is the case then inform the user ?
 Would it make sense to recover from a faulty addgroup, analyse the chunk
used, send a message to the user if it contains an http backtrace and
reraise the exception ?

-------------- next part --------------
An HTML attachment was scrubbed...
URL: http://www.selenic.com/pipermail/mercurial/attachments/20061118/c06c4280/attachment.html

More information about the Mercurial mailing list