Problem with new installation web interface

Ry4an Brase ry4an-mercurial at ry4an.org
Sat Mar 1 22:00:45 CST 2008


On Tue, 26 Feb 2008 at 05:11:26 +0000, Matt Nordhoff wrote:
>
> Get the hgweb.cgi script that goes with your hg version. If you are
> using the development version, update it. If you're using a release, get
> it from the source tarball. If you don't have the source tarball, you
> can get it from somewhere like:
> 
> 0.9.5: <http://selenic.com/repo/hg-stable/raw-file/0.9.5/hgweb.cgi>
> 0.9.4: <http://selenic.com/repo/hg-stable/raw-file/0.9.4/hgweb.cgi>
> 
> (Where did you find a link to that version of the file? It would be good
> to know so that that source can be corrected...)

I made the same mistake initially too.  I think it came from the hg book
section 6.6.2:

    To get started, find the hgweb.cgi script that should be present in
    your Mercurial installation. If you can’t quickly find a local
    copy on your system, simply download one from the master Mercurial
    repository at http://www.selenic.com/repo/hg/raw-file/tip/hgweb.cgi.

The RPM placed hgweb.cgi somewhere unexpected so I grabbed the tip per
the book's suggestion.  After a bit of wrestling with the python errors
(and a day for my nightly updatedb) found the hgweb.cgi that matched my
version.

-- 
Ry4an Brase - http://ry4an.org/


More information about the Mercurial mailing list