hgwebdir backward compatibility issue in 1.5.x

Yuya Nishihara yuya at tcha.org
Wed Apr 7 07:12:24 CDT 2010


Hi,

TK Soh wrote:
> On Tue, Apr 6, 2010 at 7:14 PM, Greg Ward <greg-hg at gerg.ca> wrote:
> > On Mon, Apr 5, 2010 at 7:25 PM, TK Soh <teekaysoh at gmail.com> wrote:
> >> Debugging on my app server was a little tricky, since I have to
> >> actually install/upgrade Mercurial for testing (while no one is
> >> connecting to the server). Any tip on such debugging would be
> >> appreaciated.
> >
> > Use "hg serve" and hit it with URLs that work under 1.4 but fail under 1.5?
> 
> The problem for me is on hgwebdir.cgi (which bombs out on invalid repo
> paths). Access to the repo appear to be fine. I don't think hg serve
> has much to do with it, right?

hg serve --webdir-conf can be used if the problem sticks on hgwebdir_mod.


More information about the Mercurial mailing list