unknown exception encountered

Peter Nabbefeld peter.nabbefeld at gmx.de
Tue Jun 21 03:53:15 CDT 2011


Got the following error message:

C:\nb\main>hg heads .
changeset:   195842:000000000000
** unknown exception encountered, details follow
** report bug details to http://mercurial.selenic.com/bts/
** or mercurial at selenic.com
** Python 2.6.4 (r264:75708, Oct 26 2009, 08:23:19) [MSC v.1500 32 bit 
** Mercurial Distributed SCM (version 1.5.4)
** Extensions loaded:
Traceback (most recent call last):
   File "hg", line 27, in <module>
   File "mercurial\dispatch.pyc", line 16, in run
   File "mercurial\dispatch.pyc", line 30, in dispatch
   File "mercurial\dispatch.pyc", line 50, in _runcatch
   File "mercurial\dispatch.pyc", line 471, in _dispatch
   File "mercurial\dispatch.pyc", line 341, in runcommand
   File "mercurial\dispatch.pyc", line 522, in _runcommand
   File "mercurial\dispatch.pyc", line 476, in checkargs
   File "mercurial\dispatch.pyc", line 470, in <lambda>
   File "mercurial\util.pyc", line 401, in check
   File "mercurial\commands.pyc", line 1490, in heads
   File "mercurial\cmdutil.pyc", line 687, in show
   File "mercurial\cmdutil.pyc", line 713, in _show
   File "mercurial\localrepo.pyc", line 315, in nodetags
   File "mercurial\localrepo.pyc", line 250, in tags
   File "mercurial\localrepo.pyc", line 271, in _findtags
   File "mercurial\tags.pyc", line 96, in findglobaltags2
   File "mercurial\tags.pyc", line 320, in _writetagcache
AssertionError: trying to write nullid to tag cache

Did the following steps:
1. Stopped hg fetch task -> local copy was broken.
2. 'hg recover' to repair
3. Fetch not possible, because latest fetch was from about a week ago -> 
not at tip.
4. Used 'hg update', then tried to fetch again: "abort: multiple heads 
in this branch (use "hg heads ." and "hg merge" to merge)"
5. Tried 'hg recover': "no interrupted transaction available"
6. Tried 'hg heads': see above error output.

Kind regards

More information about the Mercurial mailing list